安装node.js版本



  • 我在终端里面查看node.js的版本(node --version)的时候,它告诉我是v4.5.0,但是我用brew update + brew upgrade node的时候,它告诉我 Error: node 6.6.0 already installed。请问这是怎么回事?



  • 可能你brew 里配置里不同 目录,系统默认启动的版本目录没有被更新。



  • 你需要查一下如何switch nodejs 版本



  • @zhewangjoe 已经装成了最新版本了,我用了这些命令:
    sudo brew uninstall node
    brew update
    brew upgrade
    brew cleanup
    brew install node
    sudo chown -R $(whoami) /usr/local
    brew link --overwrite node
    sudo brew postinstall node



  • 这时node -v 还是显示4.x? 那试着装的时候指定node的版本呢?



  • @zhewangjoe 0_1474346782056_upload-4ed08e89-acab-450d-b4a8-59391b1bb823
    谢谢老师,已经成为最新版本了,不过我之前想指定安装版本,不知道怎么写命令行,请教老师如何指定版本安装?:slight_smile:



  • brew search node
    会看到都有什么版本
    之后brew install的时候 指定版本 比如说
    brew install homebrew/versions/node010



  • 0_1474347836975_upload-6b48e031-979a-4096-ad14-f4b1dc3c0ea7


登录后回复
 

与 BitTiger Community 的连接断开,我们正在尝试重连,请耐心等待